Can't open any page as returns error "Server Error in '/' Application."

Aug 31, 2010 at 10:48 AM

Hi,

Please can anyone help? I've managed to deploy the Calendar Webpart fine onto the customised masterpage and displays okay but now when i try to access other pages, i now get an error listed as follows;

Value does not fall within the expected range.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.ArgumentException: Value does not fall within the expected range.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.


Stack Trace:

[ArgumentException: Value does not fall within the expected range.]
   Microsoft.SharePoint.SPListCollection.GetListByName(String strListName, Boolean bThrowException) +418
   Microsoft.SharePoint.SPListCollection.get_Item(String strListName) +54
   CalendarWebpart.CalendarWebpart.cal_DataBinding(Object sender, EventArgs e) +314
   System.Web.UI.Control.OnDataBinding(EventArgs e) +132
   System.Web.UI.Control.DataBind(Boolean raiseOnDataBinding) +170
   CalendarWebpart.CalendarWebpart.CreateChildControls() +726
   System.Web.UI.Control.EnsureChildControls() +146
   System.Web.UI.Control.PreRenderRecursiveInternal() +61
   System.Web.UI.Control.PreRenderRecursiveInternal() +224
   System.Web.UI.Control.PreRenderRecursiveInternal() +224
   System.Web.UI.Control.PreRenderRecursiveInternal() +224
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3394

Please can you advice?

 

 

Coordinator
Aug 31, 2010 at 12:24 PM

The webpart must be placed on a webpart page and its properties must be set.

Sep 3, 2010 at 2:36 PM

Thanks as that does work but now what i want to do, is to set it up or rather amend it onto the master page. So that i don't have to include it onto every page or subsite that i create but rather it becomes standard/part of the site. And what i've also picked up is that, when i make it part of the master page, code wise it opens up fine on the default page as well as when i create a new page it works fine. But on the existing pages or sites, it breaks and displays the same error message as above. Please help?

Coordinator
Sep 3, 2010 at 2:41 PM

Did you set its properties (listid, fieldid)?

Sep 3, 2010 at 3:16 PM
Edited Sep 6, 2010 at 7:49 AM

Yes, as i first created the Event Calendar list and thereafter assigned or rather setup all its properties as advised.

Mar 14, 2011 at 6:56 PM

I have the same problem, how can I fix this? this is urgent please!!

Coordinator
Mar 14, 2011 at 9:04 PM

You can also do another trick: add the webpart on a webpage, than export it from the page and import it back into the webpart gallery.

Mar 14, 2011 at 10:25 PM

still the same problem,! what can I do, your webpart looks really great and would save a lot of time! please hel!!!

Apr 18, 2011 at 7:15 PM

I can't seem to get as far as the rest of you - as soon as a run the deploy command I start getting:


Error is: Server Error in '/' Application
Line 9: <%@ Register TagPrefix="wssuc" TagName="Welcome" src="~/_controltemplates/Welcome.ascx" %>


Source File: /_catalogs/masterpage/BlueBand.master

Any clues on that one? I suppose that I would need to update the masterpage even though it's not custom?